Unit-1
Ms windows
Operating system definition and functions
Introduction to operating system.
An operating system act as an intermediary between the user of a computer and computer hardware. The purpose of an operating system is to provide an environment in which a user can execute programs in a convenient and efficient manner. 
An operating system is a software that manages the computer hardware. The hardware must provide appropriate mechanisms to ensure the correct operation of the computer system and to prevent user programs from interfering with the proper operation of the system.

Definition of Operating System:
 
· An Operating system is a program that controls the execution of application programs and acts as an interface between the user of a computer and the computer hardware. 

· A more common definition is that the operating system is the one program running at all times on the computer (usually called the kernel), with all else being applications programs. 
· An Operating system is concerned with the allocation of resources and services, such as memory, processors, devices and information. The Operating System correspondingly includes programs to manage these resources, such as a traffic controller, a scheduler, memory management module, I/O programs, and a file system. 


Functions of Operating System 

Operating system performs three functions: 
1. Convenience: An OS makes a computer more convenient to use. 
2. Efficiency: An OS allows the computer system resources to be used in an efficient manner. 
3. Ability to Evolve: An OS should be constructed in such a way as to permit the effective development, testing and introduction of new system functions without at the same time interfering with service.

Services offered by offered operating system-
1. Program execution
 2. I/O operation
3. File system manipulation 
4. Communications
5. Error detection

1. Program execution: Operating system loads a program into memory and executes the program. The program must be able to end its execution, either normally or abnormally.
2. I/O Operation : I/O means any file or any specific I/O device. Program may require any I/O device while running. So operating system must provide the required I/O.
 


3. File system manipulation : Program needs to read a file or write a file. The operating system gives the permission to the program for operation on file.
4. Communication : Data transfer between two processes is required for some time. The both processes are on the one computer or on different computer but connected through computer network. Communication may be implemented by two methods:
a. Shared memory 
b. Message passing.
5. Error detection : error may occur in CPU, in I/O devices or in the memory hardware. The operating system constantly needs to be aware of possible errors. It should take the appropriate action to ensure correct and consistent computing.

Basic components of windows:-
Icons- An icon is a small graphic representation of a program or file that, when clicked on, will be run or opened. Icons are used with Graphical User Interface (GUI) Operating Systems such as Microsoft Windows and the Apple Mac OS to help quickly identify a type of file or program associated with the icon. In the image to the right, is an example of what the My Computer icons in Microsoft Windows looks like.

When you double-click or open an icon the associated file or program will be opened. For example, if you were to double-click on the My Computer icon it would open Windows Explorer and double-clicking a document or file icon would open that document in the associated program.


Types of icons:-
1) Standardized electrical device icons- Some common computer icons are taken from the broader field of standardized icons used across a wide range of electrical equipment. Examples of these are the power symbol and the USB icon, which are found on a wide variety of electronic devices. The standardization of electronic icons is an important safety-feature on all types of electronics, enabling a user to more easily navigate an unfamiliar system. As a subset of electronic devices, computer systems and mobile devices use many of the same icons; they are incorporated into the design of both the computer hardware and on the software. On the hardware, these icons identify the functionality of specific buttons and plugs. In the software, they provide a link into the customizable settings

2) Desktop metaphor icons- A second type of hyperlink icon represents objects common in a physical office space and desktop environment. It includes the basic icons used for a file, file folder, trashcan, inbox, together with the spatial real estate of the screen, i.e. the electronic desktop. This model originally enabled users, familiar with common office practices and functions, to intuitively navigate the computer desktop and system The icons stand for objects or functions accessible on the system, and enable the user to do tasks common to an office space. These desktop computer icons developed over several decades; data files in the 1950s, the hierarchical storage system (i.e. the file folder and filing cabinet) in the 1960s, and finally the desktop metaphor itself (including the trashcan) in the 1970s

3) Brand icons for commercial software-- A further type of computer icon is the brand icon of commercial third-party software programs available on the computer system. These brand icons are bundled with their product and installed on a system with the software. They function in the same way as the hyperlink icons described above, representing functionality accessible on the system and providing links to either a software program or data file. Over and beyond this, they act as a company identifier and advertiser for the software or company

Because these company and program logos represent the company and product itself, much attention is given to their design, done frequently by commercial artists. To regulate the use of these brand icons, they are trademark registered and are considered part of the company intellectual property.

TASKBAR—
A bar located at the bottom of the screen first introduced with Microsoft Windows 95 and found in all the versions of Windows that followed. The Taskbar allows the user to locate and launch programs through the Start button, view any program that is currently open, check the date and time, items running in the background through the System tray, and with subsequent versions of the Windows operating system, the Quick Launch. 


Windows 7 Taskbar
[image: Microsoft Windows 7 Taskbar]

Windows 98 Taskbar 
[image: Windows Taskbar]

The two pictures above are examples of differences between Windows Taskbars. The first is the Windows 98 Taskbar, similar to many of the earlier versions of Microsoft Windows. The second is the latest evolution of the Windows Taskbar, originally introduced with Windows Vista. In this version of the Taskbar, the Start button is now an Orb with the Windows flag, Quick Launch icons are displayed beside the currently running programs, which are now are only shown by icon. The icons in the System tray are now hidden, and the date is below the time.
 Activating windows-
While Windows is typically set to activate automatically when you install it, you may find a time when you need to manually activate it. Activating Windows verifies that your copy of Windows is only being used by your computer hardware, which helps prevent piracy. If you’ve just upgraded your computer, or you weren’t able to get online after installing Windows, you’ll probably need to activate your copy manually. Follow this guide to learn how
Method 1 of 3: Activating Over the Internet 
1. Helpful?[image: Activate Windows 7 Step 1 Version 2.jpg]
1
Click the Start button. Right-click on Computer and select Properties. This will open the System Properties window. 
1. [image: Activate Windows 7 Step 2 Version 2.jpg]
2
Click the “Activate Windows now” link at the bottom of the window. The software will attempt to detect an active Internet connection. If one is detected, the "Activate Windows online now" option will be available for selection. If it is not available, check to make sure you are connected to the Internet. 
2. Helpful?[image: Activate Windows 7 Step 3 Version 2.jpg]
3
Enter your Windows 7 product key at the prompt. You must enter a valid 25 character key in order to activate your copy of Windows. Your product key may be located underneath your laptop, on the back of your computer case, on the disc case for your Windows 7 installation DVD, or in the Windows 7 manual. 
· If you downloaded the software online, then you will find it in your confirmation email.
· If you cannot find your product key, you may need to purchase a new one.
Helpful?[image: Activate Windows 7 Step 4 Version 2.jpg]
4
Click Next to activate your copy of Windows. The activation process may take a few moments. Once it has been completed, the activation window will display a confirmation message. To double-check that you are activated, open System Properties again (Right-click on Computer and select Properties). The bottom of the window should show the message “Windows is activated”. 
[bookmark: Activating_by_Telephone_sub]Method 2 of 3: Activating by Telephone 
1. Helpful?[image: Activate Windows 7 Step 5 Version 2.jpg]
1
Click the Start button. Right-click on Computer and select Properties. This will open the System Properties window. 
2. Helpful?[image: Activate Windows 7 Step 6 Version 2.jpg]
2
Click the “Activate Windows now” link at the bottom of the window. Select “Show me other ways to activate” from the Activation menu. 
3. Helpful?[image: Activate Windows 7 Step 7.jpg]
3
Enter your Windows 7 product key at the prompt. You must enter a valid 25 character key in order to activate your copy of Windows. Your product key may be located underneath your laptop, on the back of your computer case, on the disc case for your Windows 7 installation DVD, or in the Windows 7 manual. 
· If you downloaded the software online, then you will find it in your confirmation email.
· If you cannot find your product key, you may need to purchase a new one.
Helpful?[image: Activate Windows 7 Step 8.jpg]
4
Click Next. Select the “Use automated phone system” from the list of options. You may be prompted to enter an administrator password. If so, enter the password, and click OK. 
Helpful?[image: Activate Windows 7 Step 9.jpg]
5
Select the location that is closest to you. You will be given a list if number that you can call, and an installation ID number will be displayed in the window. 
Helpful?[image: Activate Windows 7 Step 10.jpg]
6
Call the number. You will be connected to an automated system that will guide you through the activation process. You will be prompted for the installation ID that is displayed on the screen. Use your phone’s keypad to enter it. 
Helpful?[image: Activate Windows 7 Step 11.jpg]
7
Write down the confirmation number. After you have entered the installation ID, you will be provided with a confirmation number. Write it down or type it into Notepad. Enter it into the activation window and click Next. 
· If the activation doesn’t work, you can stay on the phone to speak with a Microsoft support member.[1] 
[bookmark: Activating_by_Modem_sub]Method 3 of 3: Activating by Modem 
1. Helpful?[image: Activate Windows 7 Step 12.jpg]
1
Click the Start button. Right-click on Computer and select Properties. This will open the System Properties window. 
2. Helpful?[image: Activate Windows 7 Step 13.jpg]
2
Click the “Activate Windows now” link at the bottom of the window. Select “Show me other ways to activate” from the Activation menu. 
3. Helpful?[image: Activate Windows 7 Step 14.jpg]
3
Enter your Windows 7 product key at the prompt. You must enter a valid 25 character key in order to activate your copy of Windows. Your product key may be located underneath your laptop, on the back of your computer case, on the disc case for your Windows 7 installation DVD, or in the Windows 7 manual. 
· If you downloaded the software online, then you will find it in your confirmation email.
· If you cannot find your product key, you may need to purchase a new one.
Helpful?[image: Activate Windows 7 Step 15.jpg]
4
Click Next. Select “Use my modem to connect directly to the activation service.” You may be prompted to enter an administrator password. If so, enter the password, and click OK. 
Helpful?[image: Activate Windows 7 Step 16.jpg]
5
Select the location closest to you from the drop-down list. Click Next to connect and attempt to activate. You will hear your modem turn on and connect to the activation service. The activation process may take a few moments. Once it has been completed, the activation window will display a confirmation message. 
· To double-check that you are activated, open System Properties again (Right-click on Computer and select Properties). The bottom of the window should show the message “Windows is activated”.
Using desktop:-
Other icons on the desktop can be shortcuts to files, folders, and application launchers. To open a folder or launch an application, double-click on its icon. 
[bookmark: GR-DESKTOP-DESKTOP][image: https://www.centos.org/docs/4/html/rhel-sbs-en-4/figs/desktop/firstdesk.png]
Figure  The Graphical Desktop
Adding File Links
To place a link to a file or directory on the desktop: 
1. Open User's Home and navigate to the appropriate directory.
2. Right-click on the icon of the file or directory and select Make Link. This creates a new icon with the phrase "link to ..." in its name. 
3. Drag and drop this new icon to the desktop. If you were to drag and drop the actual file or directory, you would move it from its current location to the desktop.
[bookmark: GR-DESKTOP-FILELINK][image: https://www.centos.org/docs/4/html/rhel-sbs-en-4/figs/desktop/link.png]
Figure  Example of a link to a file

Title bar:-
In computing, the title bar is a graphical control element and part of the window decoration. As a convention it is located at the top of the window as a horizontal bar.

Default title-bar text often incorporates the name of the application and/or of its developer. The name of the host running the application also appears frequently. Various methods (menu-selections, escape sequences, setup parameters, command-line options — depending on the computing environment) may exist to give the end-user some control of title-bar text. Document-oriented applications like a text editor may display the filename or path of the document being edited. Most web browsers will render the contents of the HTML element title in their title bar, often pre- or postfixed by the application name. Google Chrome and some versions of Mozilla Firefox place their tabs in the title bar. This makes it unnecessary to use the main window for the tabs, but usually results in the title becoming truncated.

The title bar often contains widgets for system commands relating to the window, such as a maximize, minimize, rollup and close buttons; and may include other content such as an application icon, a clock, etc.

In many graphical user interfaces, including the Mac OS and Microsoft Windows interfaces, the user may move a window by grabbing the title bar and dragging.
Working with Windows Desktop 
Graphical User Interface - Each type of file is represented by a picture and description, and each command is represented by a button. Programs are arranged on a series of menus to make them easy to locate. 
Windows XP Desktop 
Desktop and Taskbar - The most basic element of the Windows user interface is a background screen called the desktop. All programs are opened over this background screen. The taskbar at the bottom of the screen is used by Windows to give you information regarding tasks on your computer and provides a way of easily opening and closing programs. 
Icons - Icons are graphics that identify programs and can be double-clicked to start the associated program. How many icons are on your computer? Go to Start > Find > Files or Folders and type *.ico into the Named box and Look in: (C:). 
Screen Tip 
ScreenTips - Below the icon is the name of the element it represents. If the name is too long, it is truncated by an ellipsis (...) when it is not selected, and displayed in full when you click it. Positioning the mouse pointer over an icon usually displays a box, called a ScreenTip, with information about the program. 
2 
The Mouse 
Clicking buttons on the mouse issues various commands. The command varies according to where the pointer is on the screen and how the clicks are done. 
Click – To click, use the left-most button. Don’t move the mouse as you click, that will select text instead. Clicking can do numerous things. It is used to place a cursor in an appropriate place in a box or text document so that typing will go in the right place. It can be used to activate a toolbar button or drop-down menu. It can be used to follow an Internet link, resize a window or many other things. 
Double-Click – This command is executed using the same button as a click, but in this case, you click twice quickly. Usually, you double-click to open a program or a file and single-click the rest of the time, but there are exceptions. 
Right-Click – Clicking the right button will often bring up a short menu on your screen from which you can select (by moving your mouse pointer over a choice and left-clicking). If you don’t want to select from the resulting menu, click somewhere on the screen away from it. 
Drag and Drop – If you click and hold down instead of letting up, your pointer turns into something like a magnet, grabbing the objects your arrow is over and dragging them to wherever the mouse moves. 
Recycle Bin Icons 
Using the Recycle Bin - This is where Windows temporarily stores files you have deleted and where you can manage deleted files. You can recover deleted files from the Recycle Bin, or you can empty the Recycle Bin and permanently delete the files to free up space on your hard drive 
Shortcut 
Shortcuts - Some icons are placed on the Windows desktop when you install the programs they represent. If the icon has an arrow in its bottom left corner, it is a shortcut. Shortcuts are links to programs that are stored in another location. If you delete a shortcut, you are not actually deleting the file, folder, or program to which it points. 
Taskbar - The taskbar is located by default along the bottom of the desktop and displays information about programs you are using. The taskbar is your link to current information on your Windows XP computer. In addition to the Start button, the taskbar displays a button for each open program. 
3 
Taskbar Buttons - You click a taskbar button to activate the window of the program it represents. The taskbar buttons are resized depending on the number of programs that are currently open, and they disappear when you close the programs they represent. 
• Taskbar Location - By default, the taskbar displays one row of buttons and is docked at the bottom of the desktop, but you can control its size and position. 
• Notification Area (System Tray) - The notification area is located at the right end of the horizontal taskbar or at the bottom of the vertical taskbar. By default, the notification area displays the current time. You can expand the area, to show more icons, by clicking the arrow . 
• Quick Launch Toolbar - The taskbar can also display its own set of toolbars. The most frequently used of these is the Quick Launch toolbar, which displays single-click links to programs and commands. 
o Toolbar Links - Windows XP installs links to Microsoft Internet Explorer , Microsoft Windows Media Player , and the Show Desktop command on the Quick Launch toolbar. You can add more program shortcuts to the Quick Launch toolbar at any time by dragging a program or shortcut icon onto it. 
• Grouped Instances - If you start the same program more than once so that several instances of the program are open at the same time -- for example, two Microsoft Word documents -- similar windows are grouped onto one button that is labeled with the name of the program. 
• Other Properties - When the taskbar is docked on the left or right, you can adjust its width from nothing (only the border is visible) to up to half the width of your screen. You can also stipulate that the taskbar should be hidden when you are not using it, or that it should always stay on top of other windows so that it is not accidentally hidden. 
• Taskbar Lock - You can lock the taskbar to prevent it from being changed; however, you cannot move or change the taskbar while it is locked. 

Create a custom toolbar 
1. Create an empty folder anywhere on your system (for example C:\Toolbars). This will keep your toolbars organized if you create more than one. 
2. Within that new folder create an additional folder with the name of your toolbar. I created the folder progs to hold the shortcuts. (Tip: The shorter the name, the less space it will use in your taskbar). 
4 
3. Now create the shortcuts for your new toolbar in that folder by dragging them in there or right click and select New Shortcut 
4. Now right-click the toolbar and select Toolbars > New. 
5. In the New Toolbar dialog box, navigate to the folder you just created. Select it and click OK. 
6. There is your new toolbar, click on it and it will pop up all the shortcuts you created. It will initially expand, but you can size it by dragging. Once it's resized, it will remain like that. 
You can create multiple toolbars and turn them on or off as you need them (right click and select Toolbars, then check the ones you want to show. 
Tip - There are almost always two and often three or more ways to do the same thing in Windows. 
5 
Start Menu 
Using the Start Menu - The Start menu contains a list of options that provide a central link to all the programs installed on your computer, as well as to all the tasks you can carry out with Windows XP. You open the Start menu by clicking the Start button at the left end of the taskbar. 
Link List - A list of links to your most frequently used programs, which includes the last six programs you started, is located below the first horizontal line on the left side of the Start menu. 
Link Types - On the right side of the Start menu are links to the locations where you are most likely to store the files you create, a link to a directory of other computers on your network, and links to various tools that you will use while running your computer. The commands you will use to log off or shut down your computer are located at the bottom of the Start menu. 
Secondary menus - As with other types of menus in Windows XP, the right-pointing arrows indicate that clicking the menu entry, or simply hover the mouse pointer over it for a few seconds, will open a secondary menu. 
Moving between Windows - When you have several windows open, you can use the taskbar to move among them. Click on the taskbar button for the program you want to move to and it will move to the front of the screen. There are a few bars and buttons that display information and control the size of the window display. 
Resize a Window 

• Title Bar and Scroll Bar - The name of the opened program or file appears in the title bar at the top of the window. If the content of the window is too large to fit in the window, a scroll bar is displayed down the right side and/or across the bottom of the window. 
• Minimize Button - When you click the Minimize button near the right end of the title bar, the window is minimized so that it is no longer visible on the desktop. The program is still running and is represented by a button on the taskbar. 
• Maximize and Restore Down Buttons - If you click the Maximize button, the window expands to fill your entire screen. If you click the Restore Down button, the window returns to its original size. The Restore Down button is available only when the window is maximized. 
• Resizing Windows - You can manually resize a window by positioning the mouse pointer over the window's frame and, when the pointer changes to a double-headed arrow, dragging the frame to make the window smaller or larger. You cannot manually resize maximized windows; you must first restore the window to its non-maximized state. 
• Close Button - If you click the Close button, the window closes which closes the program and removes the corresponding button from the taskbar. 

Show Desktop - The Show Desktop button on the Quick Launch toolbar at the left end of the taskbar minimizes any open windows. 
Display Properties 
With the Display Properties window you can personalize the look and feel of your PC. To access the Display Properties dialog box click Start > Control Panel > Display or right-click on an open area of your desktop and select Properties. 
The Themes tab has several sets of background, icons, and "earcons" (sounds). You can come up with a combination you like and then save it. 
Use the Desktop tab to choose the background, or wallpaper, for your desktop. These .bmp and .gif files are also available in the C:\WINDOWS\ folder. You can browse to make any image on your computer the background. You can right-click on almost any image in your browser and one of the options will be Set as Background. 
Use the Screen Saver tab to choose yours. Depending on the capabilities of the screen saver program, the Settings button may give you some handy options. Remember that screen savers load in RAM and a fancy one can slow your computer. 
Use the Appearance tab to finely tune the look of your windows. The Advanced button will give you more options. You can make item-by-item changes by pulling down that menu. For example, if you select icon in the Item menu, you'll be able to change the size of the icons on your desktop as well as the color, font face, and size of the words labeling it. The Effects options, give you yet more ways to change some subtle visual effects. 
Back in the Themes tab, you can save your new look and feel so that you can switch to it at any time. 
In the Settings tab, you can change the resolution of your monitor (actually, you are resizing your desktop). The most common screen sizes (measured in pixels) are: 
• 800 x 600 
• 1024 x 768 
• 1152 x 864 

Display Properties Window 
To change the screen resolution: 
1. Right click on the desktop and click Properties. 

This will open the Display Properties window. 
2. Click on the Settings tab. 
3. Move slider to desired screen resolution and click Apply. 
4. Click OK to close the window. 

File and Folder Management 
Files and Folders - Windows Explorer is the interface designed to help you manage and manipulate your files and folders. Your computer stores information in the form of files, of which there are many types. Some are used to run programs, some are created by programs, and some are created by you. 
• System Folders - Files are organized on your computer in folders. When Microsoft Windows XP is installed on a computer, it creates four system folders, which are Documents and Settings, Program Files, temp, and WINDOWS or WINNT. 
• Documents and Settings - The Documents and Settings folder contains a subfolder for each user profile -- each user who has logged on to the computer or who has logged on to a network domain through the computer. 
• Program Files - The Program Files folder is the folder where most programs install the files they need in order to run. 
• Temp and WINDOWS or WINNT - The operating system and various other programs might store temporary files in the temp folder. Most of the critical operating system files are stored in the WINDOWS or WINNT folder. It is highly recommended that you do not alter these files in any way. 

Tip - The terms directory and folder are used interchangeably by most people. 
Anatomy of a File Name 
File Names and Extensions - All files have names, and all file names consist of two parts - the name and the extension separated by a period. The type of file or the program in which it was created is indicated by the extension. The extension is a short abbreviation of the file type, usually consisting of three letters, sometimes two or four. By default, Windows XP hides file extensions. 
Regardless of what you name the extension, the information in the file still has a certain type of content. A text file is very different from an audio file. If you try to open a spreadsheet with an image editor, it won't work. Nor can you turn a text file into an image just by changing the extension. As long as the extension is appropriate to that content type, then the question becomes, what application will open or view or play it? You have dozens of choices, but you have to settle on one. 
For a list of every available file format, go to this link: 
Whatis?com's - http://whatis.techtarget.com/fileFormatA/0,289933,sid9,00.html 
Tip - If your file extensions aren't showing, in Windows Explorer, pull down the Tools menu and select Folder Options > View. Uncheck the box next to "Hide file extensions for known file types". 
File Icons - Files also have icons, which are graphic representations of the file type. Depending on the way you are looking at your files, you might see a large icon, a small icon, or no icon. 

Computer Exploration - You can use Windows Explorer to view all the files, folders, drives, and peripherals on your computer, as well as those on any computers you are connected to through a network. Windows Explorer has two views, which are the Folders view and Tasks view. 
Explorer Views 
Folders View. Folders view displays the hierarchical structure of files, folders and subfolders, drives, and peripheral storage devices on your computer. Click Folders in the toolbar to toggle this option. 
Tasks View. Tasks view displays links to tasks and places that are related to the folder you are currently looking at. The tasks and places are updated automatically based on the contents of the folder. 
Folder Opening - You can open a specific folder in Windows Explorer by using the Start menu options or the Windows Explorer Address Bar. 
Display Windows Explorer - You can quickly display Windows Explorer by right-clicking the Start button and clicking Explore. If you have a Windows key on your keyboard, you can hold down this key and press e. 
Display Variation - Your specific Windows Explorer display can vary depending on the hierarchical structure of your computer and whether you have explored its contents before. For example, the Address Bar might not be visible in your Windows Explorer window. 
Windows Explorer Window 
Menu Bar Contents - Below the title bar, most windows have a menu bar with several categories of actions, called menus. Each menu lists a number of commands that you can carry out on the files and folders displayed in the window. Below the menu bar you see one or more toolbars of various types. These toolbars provide buttons that enable you to carry out common actions, often with a single mouse click. 
Folders View - Folders view in Windows Explorer displays the folder structure on the left and the contents of the selected folder on the right. For example, when the My Documents folder is selected on the left, its contents are shown on the right. This is the traditional Windows way of viewing folders and their contents. 
Root Directory - The folders and files stored directly on a drive are said to be stored in that drive's root directory. The first time you attempt to display the contents of the root directory, you might see a warning message telling you to click a link to display the files. This is because the root directory often contains system files that should not be modified or moved in any way. The right pane of Windows Explorer displays the contents of the root directory. The subfolders displayed in the right pane are the same as those listed in the left pane. It is extremely important that you never delete files from the root directory or any of the system folders created by Windows unless you are absolutely sure you know their function. 
File Path 
Folder and File Path - The path of a folder or file gives the address where the folder or file is stored on your hard disk. A typical path starts with the drive letter and lists the folders and subfolders you have to go to, separated by backslashes (\), to find the folder or file. If the Address Bar is not visible, you can turn it on by right-clicking the toolbar and clicking Address Bar on the shortcut menu. 
Back and Forward Buttons - On the toolbar, click Back. You return to your last location. On the toolbar, click Forward. You return to the previous folder. On the toolbar, click the Up button. You move up one folder. 
View Options 
View Options - The view options for each folder are available on that folder window's toolbar, and they vary depending on the contents of the folder. Available views include the Details view, Filmstrip view, Icons view, List view, Thumbnails view, and Tiles view. 
Details View. Details view displays a list of files or folders and their properties. The properties shown by default for each file or folder are Name, Size, Type, and Date Modified. 
Filmstrip View. Filmstrip view displays the currently selected picture at the top of the window above a single row of smaller versions of all the pictures in the current folder. This view is only available for folders with images. 
Icons and List Views. Icons view displays the icon and file name for each file or folder in the current folder. List view displays a list of the files and folders in the current folder, with no additional information other than the file name and a small icon representing the file type. 
Thumbnails View. Thumbnails view displays up to four miniature representations of the files contained in each folder. 
Tiles View. Tiles view displays a large file type icon or folder icon, the file or folder name, and up to two additional pieces of information for each file in the current folder. 
Folder Properties - To view the properties of a folder right-click the folder and click Properties. The Properties dialog box appears. Look at the information on the General, Sharing, and Security tabs. Depending on where you are, there are at least three ways to get to the windows that let you change your folder properties; Start > Control Panel > Folder Options, My Computer > View > Folder Options, or Windows Explorer > View > Folder Options. 
Organization - Proper file and folder organization and storage will ease your Windows use. Each application on your computer creates files of a particular type. As you create these files, you will want to create folders in which to organize the files for easy retrieval. 
Disk Space – Your computer likely comes with a hard disk that will store several gigabytes (GB) of information. A gigabyte is 1 billion bytes, and a byte is a unit of information that is the equivalent of one character. 
Copies - There are a number of ways to make copies of files and folders, including buttons and keyboard shortcut commands. The organization methods of copying, pasting, moving, and renaming are the same for both files and folders. Right click on any icon, file or folder to access the menu for copying and pasting. See the Keyboard Shortcuts list for a complete listing of keyboard commands for copying and pasting. 
Washing Text 
Sometimes you want to copy files from one program or application to another. A common example is copying text from a browser or word processor to a web page, that is, from Microsoft's Internet Explorer or Word to FrontPage or Dreamweaver. 
Using the standard buttons or CTRL-C / CRTL-V will give the appearance of copying text, but will bring Microsoft's proprietary and unseen formatting code along with it. The unseen (hidden) part can create a file ten times the size it needs to be full of pesky formatting you can't get rid of. 
The best technique is to wash the text first. You wash off the proprietary hidden formatting code by pasting into a text editor first and then copying again to FrontPage. At first, this seems unnecessary and time-consuming. If you don't do it, however, you'll find out that the resulting mess is very time-consuming. 
To wash text: 
1. In browser or Word window, highlight text - hold down left mouse button and drag. 
2. Copy text to clipboard - CTRL-C (hold down CTRL key and press C). 
3. Switch to text editor. 
4. Paste text - CTRL-V (hold down CTRL key and press V). 
5. Highlight text again or pull down Edit menu and Select All. 
6. Repeat step 2 by coping text to clipboard. 
7. Switch to the program where you want to paste the text. 
8. Repeat step 4 by pasting text. 

File Renaming - Once you copy files or folders to their new location, you should probably rename them so you do not have multiple files with the same name. File names should reflect the file and be kept short in length. Avoid using blank spaces, hyphens or special characters such as &, * , . , or @. An example would be pc_basics.doc. 
Search Window 
File Searching - You can search for all types of objects, including files, printers, and computers, using a feature of Windows XP called Search Companion. To access the Search Companion click the Start button and choose Search from the left side menu. 
Wildcards. In searches, the asterisk (*) is a wildcard that represents any number of characters (including zero). The question mark (?) is a wildcard that represents one character. For example, enter *.txt to search for any text file; enter s*.txt to search for any text file with a file name that begins with the letter s; and enter s??.txt to search for any text file that has a three-letter file name beginning with the letter s. 
Software and Device Basics - Computers are discussed in terms of hardware and software. Physical items such as computers and monitors are hardware, and all the programs that enable you to function with that hardware are collectively known as software. 
Peripheral Devices - You will eventually want to install extra hardware, called peripheral devices, on your computer. The most common peripheral devices are speakers and printers. Other popular devices include scanners, storage devices such as Zip drives, and fax machines. These devices are all external, meaning that you can install them without having to open up your computer. Others, such as a CD-ROM burner or a tape backup drive, might be internal, meaning that they have to be installed inside your computer's case. 
Device Types - Many peripheral devices fall into a category called Plug and Play, which quite literally means that you can plug them in and use them; no setup is required. Others might require that you supply some kind of information, usually through a wizard, or might require a specific device driver in order to work properly. 
Driver Files - Device drivers are files that contain information that Windows needs to run your printer, fax machine, scanner, camera, or other device. Drivers can be specific to an individual device or to a family of devices, such as all Dell LaserJet printers, and they are often specific to a certain version of Windows. Device drivers can be found on the Web site of the device manufacturer or on certain Web sites that centralize driver information. 
New Software Programs - In order to install new software or optional Windows XP components on your computer, you must run an executable file of some type, usually called Setup.exe. Many software manufacturers use files called autorun files, which are located in the root directory of the place from which the program is being installed -- usually a CD-ROM. 
Installation Options - Many programs offer multiple installation options, such as default, complete, and custom. Some programs that are installed from a CD-ROM offer the option of copying large files to your computer or accessing them from the CD-ROM when needed. 
Considerations. When choosing your installation type, consider how you will use the application, the amount of space the application requires, and the amount of space available on your hard disk. Also think about whether the installation source will be available to you later, in case you need to access files that are not installed to your computer or you want to re-install the application. In most cases, the default installation fits the needs of the average user and is the best choice. 
Control Panel - To learn more about your PC, you should explore the Control Panel. You can change a program's settings or remove the program altogether through the Add or Remove Programs dialog box, which is available from Control Panel. 
Uninstall a Program - You may at some point need to uninstall a program from your computer. Always use Add or Remove Programs to uninstall a program. If you just delete the folder containing the program many extra files are left on your drive. 
To remove a program: 
1. On the Start menu, click Control Panel. 
2. In the Control Panel window, click Add or Remove Programs. The Add or Remove Programs window opens, displaying a list of your currently installed programs. 
3. Click the name of the new program. The program listing expands. 
4. Click the Remove button. The uninstall program starts. 
5. Accept the default uninstall options to remove the program from your computer. 

When the uninstall process is complete, the icon no longer appears on your desktop. 
Local Printer Installation - A local printer is a printer that is connected directly to your computer. The software to run the printer is installed on and run from your computer. When you connect a printer to your Windows XP computer, Windows XP often identifies that the printer has been connected. It then searches through its database of drivers to locate the appropriate software to run the printer. 
Network Printer - A network printer is a printer that is not connected directly to your computer. Instead, you access the printer over the network, either as a free-standing networked printer, through someone else's computer, through a print server, or through a printer hub. Contact Help Desk for assistance with networked printers. 
Storage Device Fundamentals - A variety of data storage devices are available; the most common are hard disk drives and floppy disk drives. When you need extra storage space, it is quite simple to install a Zip disk drive, CD-Read-Write drive or USB drive. 
Port Types - Most computers come equipped with a standard set of ports that you use to connect a keyboard, mouse, monitor, or printer. If your computer has a sound card and a network card, you also have audio and network ports. Many desktop and laptop computers now also have USB ports to handle the growing number of devices that are designed to work with this method of connection. 
Computer Maintenance 
Some useful utilities come bundled with Windows. To access these system tools select Start > Programs > Accessories > System Tools. Explore each of these. Note especially the maintenance features on the System Tools menu. You should regularly use, especially when your computer starts to run sluggishly: 
Hard Disk Cleanup - With prolonged usage, your hard drive can become cluttered with temporary files. Every time you open a file, access a Web page, install a program, or download a file, a temporary file is created in a specific directory on your computer. Most of these files are deleted automatically when no longer needed. 
Unnecessary Files - Poorly designed programs do not delete temporary files properly, resulting in unnecessary files on your hard disk. Other types of unused files can also clutter up your hard disk. The Recycle Bin application, which stores deleted files until you empty it, is a common cause of undeleted files. 
Release Space - You can use Disk Cleanup to release space on your hard disk by removing downloaded program files, temporary files, and offline files. Disk Cleanup compresses old files and empties the Recycle Bin. 
Disk Cleanup 
To run Disk Cleanup Click Start > All Programs > Accessories > System Tools > Disk Cleanup. Disk Cleanup will run and provide you with a list of categories available for deletion. Select the check boxes of all categories that have files available for deletion. The total amount of disk space that will be freed up is indicated within the dialog box. Click OK to delete files. 
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Disk Defragmentation - Your hard disk can become fragmented over time, which can cause your computer to operate less efficiently. You can use Disk Defragmenter to analyze the data stored on your hard disk, and then consolidate fragmented files and folders into contiguous chunks to create the largest possible areas of available space. 
Disk Defragmenter 
To run Disk Defragmenter: 
1. Click Start > All Programs > Accessories > System Tools > Disk Defragmenter. The Disk Defragmenter window opens. 
2. Click Analyze for Disk Defragmenter to analyze your drives. After analyzing the drives, it will display a message recommending defragmentation. Click Defragment to defragment your drives. 

Windows Update - Microsoft Windows Update is an Internet-based service that scans your computer and recommends or installs any updates that are available for the operating system, software programs, or hardware. Windows Update ensures that your computer is equipped with security patches as they become necessary and available. To run update: 
1. Click Start and select All Programs. 
2. Click Windows Update from the top of the menu. This will open up Internet Explorer. 
3. Follow the directions from the Windows Update page. 

Windows will notify you when the updates are complete. Occasionally this will require you to reboot your computer. 
Helping Yourself - When problems occur, it is important to be able to find solutions on your own. Windows XP includes new tools that allow you to find solutions to problems without external help. 
Help and Support Center - The help offered includes multimedia product tours targeted at different audiences, general and specific articles, a comprehensive glossary, tutorials and demonstrations, and links to most of the tools that you need to keep your computer running smoothly. You can choose from a list of common topics on the main page of the Help and Support Center, search the database by keyword or phrase, or look up specific topics in the index or table of contents. You can access the Help and Support Center by choosing Help and Support from the Start menu, or by pressing the F1 key on the keyboard.
Unit-2
Documentation using MS-Word

 INTRODUCTION

Word processing is an application program that allows you to create letters, reports, newsletters, tables, form letters, brochures, and Web pages. Using this application program you can add pictures, tables, and charts to your documents. You can also check spelling and grammar.

In this lesson, we will learn Word 2007 and use its features, tools and techniques. All Professional Documents will be discussed using this package only.


 OBJECTIVES

After going through this lesson you would be able to:

l	define features of Word 2007

l	explain basic menu details of Word 2007

l	create, save and print new Word document

l	protect a word document quickly and efficiently

l	manage word files and their printing

MAIN FEATURES OF WORD PROCESSING

The main features are:

l	You can create professional documents fast, using built-in and custom templates.

l	You can easily manage large documents using various features like the ability to create table of contents, index, and cross-references.

l	You can work on multiple documents simultaneously

l	With the help of mail merge, you can quickly create merge documents like mass mailings or mailing labels.

l	AutoCorrect and AutoFormat features catch typographical errors automatically and allow you to use predefined shortcuts and typing patterns to quickly format your documents.

l	The print zoom facility scales a document on different paper sizes, and allows you to print out multiple pages on a single sheet of paper.

l	The nested tables feature supports putting one table inside another table.

l	You can export and save your word documents in PDF and XPS file format.


FEATURES OF WORD 2007

MS Word 2007 has useful features and tools introduced to produce professionally created documents. Some of these features are discussed below.

You can easily create, format, edit professional-looking user document using comprehensive set of easy to use tools provided by MS Word. It uses the MS Office Fluent user Interface concept. This interface uses a new component called Ribbon to group the tools by task, within task by sub tasks and related commands that are used more frequently. The new user result oriented interface presents the tools to you in a more organised and efficient manner, which are easy to locate
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Fig. 2.1

1.	Tabs are more task oriented such as Home, Insert, Page Layout

2.	Within each tab, the related sub-tasks are grouped together

3.	Related command button 1 are also grouped together to execute a command or to display a command menu

The MS Word 2007 provides a lot of pre-formatted template to produce documents, reports etc. While using the pre-formatted template, you can select already available cover page, header and footer to give the documents a professional look without spending much time in formatting a new one.

MS Word 2007 also provides features for creating chart and diagram which include three-dimensional shapes, transparency, drop shadows, and other effects. This helps create highly professional documents with flexibility in representing data more efficiently and professionally.

Using MS Word 2007 digital signature feature, you can ensure the authenticity, integrity, and origin of the document. The same can be done either by adding an invisible digital signature to a document, or inserting a Microsoft Office Signature Line, which capture a visible representation of a signature along with a digital signature.

Similarly, before sharing a document which is in its final form with others, you can use MS Word 2007 “Mark As Final” features to protect the document from any changes. “Mark as Final” command makes the document “read-only” making the typing, editing and proofing command disabled. But just to remember,



“Mark As Final” is a security feature as anyone can edit a document that is marked as final by turning off Mark as Final.

MS Word 2007 also provides the feature and tools to export your document to either PDF (Portable Document Format) or XPS (XML Paper Specification) format.


STARTING MS WORD PROGRAM

You can start your Word program different ways. One way is using Start button:

1.	Click on the Start button.

2.	In the menu that appears select All ProgramsMicrosoft OfficeMicrosoft Office Word 2007. In few seconds you will see Word screen on the monitor.
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You can also start your MS Word program by double clicking on Microsoft Word icon, which lies on the Microsoft Office Shortcut Bar (MOSB).


[image: ]WORD SCREEN LAYOUT


























Fig. 2.3 Screen Layout


Menus

If you are familiar with previous versions of Word, when you begin to explore Word 2007, you will notice a significant change in the menu structure, look and feel. The features in Word 2007 display as various tabs such as Home, Insert, Page Layout, References etc. To view all sub tasks/options (expanded form) in each menu, you must click the required option. For example, the images in Figure 3.4 show the Border menu in collapsed form and in expanded form 


















[image: ]Fig. 2.4a Collapsed menu	Fig. 2.4b Expanded menu


[image: ]Shortcut Menus

These features allow you to access various Word commands faster than using the options on the menu bar. When the menu is expanded, the shortcut menu is displayed with short-cut command option for each of the short-cut menu item. The options on this menu will vary depending on the sub-task that was clicked or selected. For example, the shortcut menu on the side is produced by selecting or expanding the Border option of
the paragraph sub-task of the Home Tab from
the Tab bar.	Fig. 2.5

The shortcut menus are helpful because they display only those options that can be applied to the item that was selected and, therefore, prevent searching through the many menu options.


Toolbars

MS Word 2007 provides a customized quick access toolbar to organize the tools available for easy and fast access of the commands. Many toolbars displaying shortcut buttons are also available to make editing and formatting quicker and easier. The toolbars that are already displayed on the screen are checked. To add/modify simply click on the “More Commands” option which will display the following menu for customized selection of tools as per your requirement.
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Rulers

[image: ]The rulers display horizontal and vertical scales that reflect the width and height of your typing area. The horizontal scale is invaluable when you want to quickly set tabs, margins, and indents. Select the View tab on the main MS word 2007 screen to be able to select/deselect the Ruler/Gridlines and other options.





























Fig. 2.8


 Typing Screen Objects

The open area below the rulers and toolbars is writing or typing area. There are certain objects that are a permanent part of the typing area. These are: (a) Insertion Point, (b) Mouse Pointer, and (c) End-of-Document Marker.

(a)	Insertion Point: The black vertical blinking line is the insertion point that is initially at the top left side of the


typing area. It indicates the place where your typing is inserted into the document. As you type, the blinking line continuously moves along towards right inserting in that line whatever is typed. When the up, down, left, or right arrows of the keyboard is used, the insertion point moves accordingly. When you move and place the cursor any where in the text and click, the insertion point shifts to that place from its current location indicating that it is ready to accept your typing.

(b)	Mouse Pointer: When you move the mouse around in the typing area, the mouse pointer is in the shape of a thin I-beam. As you move the mouse near the menu bar and toolbars, the mouse pointer becomes a pointing arrow. If you move the mouse pointer to some existing piece of text and click the mouse, you will see the insertion point in that spot of the text.

(c)	End-of-Document Marker: The horizontal line (like a short underline) at the end of the document (seen only when Word is in Normal view) is called end-of-document marker. This marker lets you know where the end of document occurs.

Vertical and Horizontal Scrollbars

The typing area is bordered on the right side by the vertical scroll bar with a scroll button and arrows. The single down arrow scrolls through the document line by line. The double down arrow allows you to move to the top of the next page. The double up arrow allows you to move to the top of the previous page. The double down arrow allows you to move to the top of the next page. You can also drag the vertical scroll button up and down the scroll bar to move up and down through the document.

The first bar along the bottom of the typing area is the horizontal scroll bar. To see the text that is off the right side of the screen, use the left arrow button. To see the text that is off the left side of the screen, use the right arrow button. You can also drag the horizontal scroll button to move left or right of the document.

In Word 2007, the options such as view documents and zoom is also available on the bottom bar for easy access.
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 MANAGING DOCUMENTS

[image: ]This section of the lesson explains how to open a new/ existing document, save a document, print a document, working	with	multiple documents,      protecting	a document, finding a document, and	closing       a       opened document. There are several
ways to create new documents,	Fig. 2.10 open existing documents, and

[image: ]save documents in Word. Click on the Office Button	to use one the following.

Create a New Document


To open a new document, follow one of the following methods:

[image: ]1.	Click the New Document button on the menu bar.

2.	Press CTRL+N keys on the keyboard.



 Open an Existing Document


Click on the office 2007 button at the top left corner of your screen to open an existing document, follow one of the following methods:


Office 2007 Button


[image: ]1.	Click the Open File button on the menu bar.

2.	Press CTRL+O keys on the keyboard.

3.	Each of the above method will show the Open dialog box. Choose the file and click the Open button.
 Save a New/Existing Document

To save a new/existing document that is opened, follow one of the following methods:

[image: ]1.	Click the Save button on the menu bar. 2.	Press CTRL+S keys on the keyboard.

If the document is already named and saved earlier, it will simply save the document. On the other hand, if the file is a new document then it will prompt you by opening Save As dialog box. Select the folder where you want to place your document in Save In: box, type the name of the document in File Name: box, and then click OK. You can also save a new document by choosing CTRLA on the keyboard and then selecting the above actions in Save As dialog box.

 Working on Multiple Documents












Fig. 2.11


Several documents can be opened simultaneously if you are typing or editing multiple documents simultaneously. All open documents can be arranged under the View Tab.
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 Protecting a Document

You can protect your document from being accidentally changed its format and text or from other users to get access to it.

Protecting a Document from Accessing

If you want to protect a document from other users accessing to it, give a password to your file. Follow the steps given below:

1.	When the file is open, select Office ButtonSave As command on the menu bar. The Save As dialog box appears. Move the cursor on the Tools tab on the down left side of Save As dialog box and click. A submenu will appear (see Figure 3.13).























[image: ]Fig. 2.13

2.	Click on General Options. The Save dialog box opens. You will see two boxes: Password to open and Password to modify.

3.	Type a password in Password to open box. (A password can include up to 15 character case-sensitive letters, numerals, spaces and symbols. As you type the password, Word displays an asterisk (*) for each character you type.)



[image: ]4.	Click	OK.	The Confirm Password dialog box appears (see Save dialog box and                Confirm Password dialog box in	Figure      3.14). Retype the password you typed earlier. Click OK on Confirm Password dialog box and then click OK on Save dialog box and then click OK on Save As dialog box.
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)5.	When you open the file again next time it
will ask you to type the password (see Figure 5.7b). Remember, you will not be able to open that file without the password. Also, don’t forget that the passwords are case sensitive; that is, ‘XYZ’ and ‘xyz’ are two different passwords.

Protecting a Document from Accessing (Read Only)

With this feature you can have double protection to your document. Some times you yourself may accidentally change the format of your document. You can protect your document from being accidentally changed its format as well as from other users accessing it.

Protecting a Document as Read Only Document

If you want your document be protected only for accidental changes in the format, follow the steps given below:

1.	 When the file is open, select Office ButtonSave As command on the menu bar. The Save As dialog box appears. Move the cursor on the Tools tab on the down left side of Save As dialog box and click. A submenu will appear.

2.	Click on General Options. The Save dialog box opens. You


[image: ]will see Read only recommended check box at the left side bottom of the Save dialog box.

3.	Check-mark () the Read	only recommended check box. Click OK on Save dialog box and then click OK on Save as dialog box.

Next time when you open the document	after	giving password it will prompt you with a message ‘Open as read-only?.          If          you
accidentally make changes	Fig. 2.15 and then try to save the

document, the file will not be

saved. Instead, you will be prompted by a message ‘This file is read-only’.

If you want to make changes to a document remove the check mark by clicking on Read-only recommended box, which lies below Password to open box under Save dialog box.

Modifying a Password Given to Protect a Document

If you suspect that some one knows your password and you want to change it, modify it by typing present password in Password to open: box and new password in Password to modify: box in the Save dialog box.

Protect a Document for Track changes, Comments, and Forms

Some times you may feel that your document should be reviewed by others to improve the document’s contents. The reviewers of your document can suggest some changes or comments without modifying the original document. After the review, if you wish that the changes were necessary you can incorporate them.














[image: ]Fig. 2.16

Track changes: Selecting this option from the Review Tab and Tracking sub-task, let other users to change the document but highlights all changes so that you can track changes. While a document is protected for track changes, you cannot turn off change tracking nor can you accept or reject track changes.


 Find Documents

When you forgot the name of a file, but you remember a few letters in a word that may be in the file name, use Open dialog box. Word will search through the list of files in the selected folder or device for your particular file. For example, if your file name is ‘Annual paper’ you can type the letters annual. Word will locate this file. Follow these steps to find files:

1.	 Select Office Button Open command on the menu bar. The Open dialog box will be displayed.

2.	In Look in: box, select the folder or click where you suspect your file will be located. Type few letters you remember that match with file name in File Name: box (Remember you can type upper case or lower case letters, since search is not case sensitive). If the typed letters are beginning letters of your file name, the file name will appear in the File Name: box. Click Open to open the document.

3.	 If you don’t see your file name appearing in the File Name: box as you type, move the cursor on the Tools tab on the top right side of Open dialog box. If the typed letters in the File Name: box matches with some part of your file name, all the file names matching with your typed letters along with other files will appear in Name box in the Open dialog box. If you trace your file in the box, double-click on the file name or select



the file name and then click Open in Find dialog box to open the document.
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 Close a Document

Close the current document by selecting Office ButtonClose command on the menu bar or click the Close icon if it is visible on the Standard toolbar.

PRINTING DOCUMENTS

While printing a document you have the following options in Print dialog box: (see Figure 3.18).

1.	Name of the printer (if you have more than one printers).

2.	Choose paper size, orientations, resolution etc. by pressing Properties button.

3.	Print the entire document or only current page or specific pages

4.	Print a draft copy, which omits graphics to allow faster printing.



5.	Number of copies to be printed, etc.

























[image: ]Fig. 2.18


 Printing a Document

To print a document or selected pages follow the steps given below:

1.	Open the document to be printed.

2.	 Choose Office ButtonPrint command on the menu bar. The Print dialog box will open. Select the Options like print range, Number of copes, Printer name etc. See that printer is switched on and the paper is available in the printer tray.

3.	Click OK.

 Printing a Document on a Different Paper Size

You might have created a document using some selected paper size. You may want to print that document in a different paper size or multiple pages in a single sheet of paper without disturbing the general format. You can do it using Zoom feature


in Print dialog box. Follow the steps given below to resize your document to fit into a new paper size.

If you want to print a document in a different paper size, follow the steps given below:

1.	Open the document to be printed.

2.	Choose Office ButtonPrint command on the menu bar. The Print dialog box will open. Select the Options like print range, Number of copes, Printer name etc. See that printer is switched on and the paper is available in the printer tray.

3.	Select the appropriate paper size in Scale to paper size: under Zoom in Print dialog box.

4.	Click OK.

Printing a Document’s Multiple Pages in a Single Sheet of Paper

If you want to print multiple pages of a document in a single sheet of paper, follow the steps given below:

1.	Open the document to be printed.

2.	Choose Office ButtonPrint command on the menu bar. The Print dialog box will open. Select the Options like print range, Number of copies, Printer name etc. See that printer is switched on and the paper is available in the printer tray.

3.	 Select the appropriate paper size in Pages per sheet: under Zoom in Print dialog box.

4.	Click OK.


 EXIT WORD PROGRAM

When finished your work in Word and closing all the files, you can quit the Word program by selecting Office ButtonExit command on the menu bar.


 KEYBOARD SHORTCUTS

Keyboard shortcuts can save time and the effort of switching from the keyboard to the mouse to execute simple commands. Print


this list of Word keyboard shortcuts and keep it by your computer for a quick reference.


Action Open a file New file Close a file Save As Save
Print Preview Print
Show/Hide paragraph symbols Spelling and grammar
Help Find Replace Go To
Select all - entire document

Select from cursor to beginning of line Select from cursor to end of line
Go to beginning of line Go to end of line
Go to beginning of document Go to end of document
Cut Copy Paste Undo Redo
Format painter Left alignment Center alignment Right alignment
Justified

Key Stroke CTRL+O CTRL+N CTRL+W F12
CTRL+S or SHIFT+F12 CTRL+F2
CTRL+P CTRL+* F7
F1 CTRL+F CTRL+H CTRL+G CTRL+A
SHIFT+Home SHIFT+END HOME
END CTRL+Home CTRL+End CTRL+X CTRL+C CTRL+V CTRL+Z CTRL+Y CTRL+SHIFT+C CTRL+L CTRL+E CTRL+R
CTRL+J




Delete previous word Apply bulleted list Indent
Page break Font face Font size Bold Italics Underline
Double underline Word underline All caps
Change case Subscript Superscript
Make web hyperlink Go to next cell
Go to previous cell

Go to beginning of column Highlight to beginning of column Go to end of column
Highlight to end of column Go to beginning of row Highlight to beginning of row Go to end of row
Highlight to end of row Column break Copyright ©
Date field

Go to footnotes Show/Hide ¶
Thesaurus

UNIT-3
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A spreadsheet is essentially a matrix of rows and columns. Consider a sheet of paper on which horizontal and vertical lines are drawn to yield a rectangular grid. The grid namely a cell, is the result of the intersection of a row with a column. Such a structure is called a

Spreadsheet.

A spreadsheet package contains electronic equivalent of a pen, an eraser and large sheet of paper with vertical and horizontal lines to give rows and columns. The cursor position uniquely shown in dark mode indicates where the pen is currently pointing. We can enter text or numbers at any position on the worksheet. We can enter a formula in a cell where we want to perform a calculation and results are to be displayed. A powerful recalculation facility jumps into action each time we update the cell contents with new data.

MS-Excel is the most powerful spreadsheet package brought by Microsoft. The three main components of this package are

Electronic spreadsheet Database management Generation of Charts. 

Each workbook provides 3 worksheets with facility to increase the number of sheets. Each sheet provides 256 columns and 65536 rows to work with. Though the spreadsheet packages were originally designed for accountants, they have become popular with almost everyone working with figures. Sales executives, book-keepers, officers, students, research scholars, investors bankers etc, almost any one find some form of application for it.


You will learn the following features at the end of this section.

Starting Excel 2003 Using Help 

Workbook Management Cursor Management Manipulating Data 

Using Formulae and Functions Formatting Spreadsheet 

Printing and Layout 
Creating Charts and Graphs 
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Starting Excel 2003

Switch on your computer and click on the Start button at the bottom left of the screen. 

Move the mouse pointer to Programs, then across to Microsoft Excel, then click on Excel as shown in this screen. 
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When you open Excel a screen similar to this will appear
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The options shown below is called as Menu Bar 






The collection of icons for common operations shown below is called as Standard Tool Bar 
[image: ]
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The formula bar is the place in which you enter the formula(=A3*B5) 
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The alphabets A,B… are known as columns
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This is the name of the workbook. (Book1)
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The rows are numbered as 1,2,3… 

Sheet1,Sheet2, Sheet3 are known as worksheet tabs 
[image: ]


How to use Help Menu

Click on Help, Contents and Index, then click on the Index tab. The following screen will appear 
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Type the first few letters to see the help entries for those letters. 

You can get the printout of any help topic by selecting it, right clicking and then clicking Print Topic. 

Workbook Management

Task 1: Creating a new workbook

Click on File menu and then click on New.
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Click Workbook and then click OK button. You will get the screen as shown below. 
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Enter data as shown in the figure below :
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Task 2: Saving Workbook

Click on File menu and then click save. You will get the below screen
[image: ]



























In the File name text box, type sample and then click Save button 


Task 3: Opening an existing workbook

Click on the File menu and click on Open. The open dialog box will appear 
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Click on some file (Example: sample.xls), then click on Open.

Task 4: Closing your workbook

Click on File menu, then click Close to close your workbook

Cursor Management

Task 1: Moving around the worksheet

Open sample.xls workbook. 

Move the cursor in your worksheet by using the arrow keys on the right-hand side of the keyboard. 

When you have got lots of rows of data you can move the cursor more quickly by using the PgUp and PgDn keys to move up and down a screen at a time. 

To move one screen to the right, press the Alt key and PgDn keys together. 

To move one screen to the left, press the Alt and PgUp keys together. 

To move further to the right, just keep pressing the right arrow key 

To move back to cell A1, press the Ctrl and Home keys together. 

Pressing the Home key on its own takes you back to column A To move to the last column(IV) press the Ctrl and right arrow 

keys together. 
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To move to last cell containing data, press Ctrl and End keys together. 

To move to the last row(65,536), press Ctrl and the down arrow keys together. 

You can also move the cursor with the mouse. Move the mouse pointer to the location you want. Press and release the left mouse button once when the cursor is where you want it. 

Task 2: Moving to a Specified cell

Click on the Edit menu, choose Go To. You will get the below screen 
[image: ]


















Enter the destination cell reference in the Reference text box. 

Click OK to move directly to the specified cell. 

Data Manipulation

Task 1: Entering data

Start Excel. Click File and then New. An empty worksheet appears as shown below 
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Type Expenditure in cell A1 then press down arrow key to move to cell A2. 

Type Month then press the down arrow key to move to cell A3 

Continue to type the data. The resulting worksheet should appear like the following screen. 
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Save your work by clicking File and then Save As. This dialog box appears.
[image: ]
























Type cash in the File Name text box and then click Save button. Excel automatically adds the extension .xls to your file name. 
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Task 2: Editing data

Click File and then click Open. 

Click cash.xls and then click Open. 

Move the mouse pointer to cell D4, click and release. The cell is highlighted and 18 appears in the formula bar. 

Move the mouse pointer to the formula bar and click once to the right of 18. 
[image: ]




























Use the Backspace key to delete 8,then type 4 and press Enter. Cell D4 now contains the value 14. 

Task 3: Replacing cell data

Make the cell B5 active by clicking on it. 

Type 200 and press Enter. The cell B5 will now contain the value 200 replacing old value (150). 

Task 4: Deleting cell contents

Move to cell C5 and click to select. Press the Delete key. 

The cell becomes blank. 
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Drop down the Edit menu and click Undo to reinstate the 145. Excel 97 allows 16 levels of undo. You can use Undo and Redo buttons also. 

Task 5: Copying data

Open the cash spreadsheet. Select the cells D3 to D5 

Click Edit menu and then click Copy. Select the cells F3 to F5. 

Click Edit menu and then click Paste. 
Now the cells D3 to D5 are copied into F3 to F5. 

Task 6: Moving data

Open cash.xls spreadsheet. Select the cells from B3 to B5. 

Click Edit menu and then click Cut. Select the cells G3 to G5. 
Click Edit menu and then click Paste. 

Task 7: Data Auto Fill

There is an easy method to fill the data in columns and rows. The data may be Numeric or dates and text.

To fill Slno by using auto fill
· Type Slno for 2 cells i.e 1,2 in the cells A1 and A2 respectively. 

· Select two cells and drag the Fill Handle  
[image: ]


















To fill dates in the cells
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· Type date in the cell 

· Select the cell and drag the Fill Handle 
[image: ]























We can customize the lists with different text data to minimize the redundancy of work.

Some of the lists are listed below:

1. Jan, Feb, Mar, Apr, May, June, July…. like months 

2. Sunday, Monday, Tuesday, Wednesday, Thursday…Like week days 

3. Adilabad, Anatapur, Chittor, Cuddapah… like District names 

4. Ravi, Kiran, Praveen, Rama…. like employees list 

To create a customized list follow the steps given below:

· Click Tools Menu ,Click Options then click Custom Lists tab, Then you will find the figure given below: 
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· Click NEW LIST and enter the list in the List entries window 

· Click Add button then click OK button then your list will be added to the Custom Lists. That list you can use as and when required to type. 

· Now you can Drag the fill handle (+ ) to get the list automatically. 

Using Formulae and Functions

Task 1: Entering a formulae


Click File and then click New. 

Enter the data in the new worksheet as shown below 
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Cell B6 should contain formula. Move the cell pointer to cell B6. 

Type =B3+B5(formulae and functions should always begin with = sign) 

Cell B6 will now contain the value 350 

Look at cell B6; you will see the result of the formula in the cell B6 rather than formula. 

Now repeat the appropriate formula for cell C6, D6. Save your worksheet as cash3.xls. 


Task 2: Editing Formulae

Move the cursor to the formula bar with the mouse, clicking once. 

Make the desired changes. 

When you have finished editing the formulae, press the Enter key for the changes to take effect. 

(OR) 

Edit the contents by pressing F2 key on the keyboard 

Task 3: Displaying and Printing formulae

Click Tools menu and then click Options. Click View tab. 

In Window options check Formulas check box. The below screen appears. 
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Click OK button. 

To print the worksheet with formulae displayed, click File menu and click on Print Preview. If the layout is satisfactory, click on the Print button. 

Task 4: Using the SUM function

Open cash3.xls spreadsheet.
[image: ]



















Suppose if you want the summation of the cells B3 to B5 should appear in the cell B6, then first select the cells from B3 to B6. 
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	Click the Auto Sum
	icon on the toolbar.

	
	The result of (B3+B4+B5) will appear in the cell B6.



Task 4: Copying Formulae

Open cash3.xls spreadsheet. 

If you want to copy the formula in the cell B6 to C6,D6,E6 then first select the cell B6. 

Move the cursor to the lower right corner of the cell B6. The cursor will change to + icon. 

Drag the cursor from B6 to E6 and release left mouse button. 

You will notice that the cells C6, D6 and E6 are updated immediately as shown below. 
[image: ]




























Task 5: Copying formulae using absolute addressing

Create the worksheet shown below and save ABS 

If you copy the formula in the cell c2 to c3, c4, c5 you will get the incorrect 
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result because the formula will change in the cell (C3)to B3*A10 but the value in the A10 is not defined. The reason is that we are copying relative address but not absolute address. To use absolute address move to c2 cell. 

Edit the formula to =B2+($B$2*$A$9) and press Enter key. Copy the formula to cells C3 to C5. 
[image: ]


























Formatting Spreadsheet
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Open an existing worksheet(For example cash3.xls)
[image: ]






















Move the mouse pointer to the position(column B)shown below in the column header. When the black cross appears, hold down the left button and drag the mouse to the right to increase the column width by the required amount. 
[image: ]


















Task 2: Decreasing column width

Open cash3.xls spreadsheet. 

Move the mouse pointer to the column B. When the black cross appears, hold down the left button and drag the mouse to the left to reduce the cell width. 

Task 3: Changing width of all cells in a spreadsheet
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Open cash3.xls spreadsheet 

Select the entire worksheet by clicking the Select All button (to the left of A1 cell) at the top left corner of the worksheet. The worksheet changes from white to black. 
[image: ]































Click Format menu, click Column, then click Width 

In the column width text box type 20, then click OK button. Your worksheet cells should all increase in width. 
[image: ]










You will get the below screen. You will notice that widths of all columns are now changes to 20 
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.

Click the Undo button to revert to the previous cell width.

Task 3: Inserting Columns

Open cash.xls spreadsheet. Move to cell B2 and click. 

Click Insert menu, click Columns. You will get the below screen. 
[image: ]
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Task 4: Deleting Column contents

Open cash.xls spreadsheet. 

Move the mouse pointer to column E header and click to select column E 
[image: ]





















Press Delete button. The column contents will be deleted. Click Undo button to revert to the previous screen. 

Task 5: Removing columns, rows, and cells completely

Select individual columns or rows or cells.

Click Edit menu and click Delete Task 6: Inserting a row 

When you insert a row, it is inserted above the current row, so if you want to insert a new row above row 6(between rows 5 and 6), place the cursor on a cell in row 6 and 

Click on the Insert menu. 

Click Entire Rows insert a blank row between rows 5 and 6. 

Task 7: Deleting row contents

Open cash.xls spreadsheet. 

Move the mouse pointer to row 2 header and click to select the row as shown below 
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Press Delete to remove the contents of row. 

Click the Undo button to cancel the delete operation. 

Task 7: Inserting cells

Open cash.xls spreadsheet. 

Select cells B2 to D4 by moving the mouse pointer to cell B2, holding down the left mouse button and dragging the mouse pointer to cell D4, then releasing the left button. The cells should be highlighted. 
[image: ]























Click Insert menu and click Cells. This dialog box appears. Click OK to shift the cell down. 
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Task 8: Changing data justification

Open cash.xls spreadsheet. 
Select the cell B2 as shown below. 

Here the text “Jan” by default left justified. You can modify alignment as right justified or center by clicking right justify 
[image: ]
or center the text 

within the cell by clicking respectively.

Task 9: Merge and Center data

Open cash.xls spreadsheet. 

Select the cells A1 to H1 as shown below 
[image: ]










Click Merge and Center button on the toolbar 

You will get the below screen. 
[image: ][image: ]
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Task 10: Formatting cells
[image: ]













Create a new spreadsheet as shown below and save it as “marks.xls” 

Now you can format the cells in column C by selecting column C by clicking on the column heading 
[image: ]






























Click Format menu and click on Cells. Click on Number. 
Use the Down arrow in the Decimal Places to set to 0. Click 

OK. 

Now repeat the formatting but this time format the cells to two decimal places. 
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Again, repeating the formatting operation, but this time to four decimal places. 

Finally, format the cells to eight decimal places. This screen will appear. 

The #### symbols indicate that the cell is too narrow to display the data in the chosen format. However, if you increase the cell width sufficiently, the data will be displayed to eight decimal places. 

Increase the width column C until the data is displayed. 

Now change the formatting back to two decimal places, and reduce the column width to a suitable width. 

Changing the data Orientation (Vertical, Horizontal etc.)

Excel offers three options that let you control the orientation of the text within a cell. These are Text alignment, Text orientation, and Text control. 
[image: ]
































Vertical text alignment can be any one of the following
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To display text vertically in a cell:


· Choose Cells from the Format menu. 

· Click the Alignment Tab. 

· Specify the desired text orientation by selecting one of the orientation boxes. 

· Select the Wrap text check box, if you want Excel to wrap the text 
· Click OK 

Here are some examples of the different alignment options
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· Select vertical list box and select top to align the data at the top of the cell (Eg: cell A1) 

· The below figure shows you different Text control options. 
[image: ]





Printing and layout

Task 1: Previewing a printout

Open cash.xls spreadsheet. 

Click on the File menu and click on Print Preview. A screen similar to this should appear. 
[image: ]
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Since the size of the text is very small, you can click on Zoom button, it magnifies the worksheet. Clicking on Zoom second time returns you to the original preview format. 

Press PgDn to move through your worksheet if it is more than one page long. 

Before printing make sure that your printer is switched on, is loaded with the appropriate paper, and is on-line. 

If you are happy with the layout of your document, click on the 


Print button to obtain a printout. You should see a message on screen telling you that your file is being printer, and on which paper. 
[image: ]
Task 2: Printing landscape

To select landscape mode, click on the File menu, Page Setup this screen will appear. 

Click on the Landscape button. 
[image: ]































Task 3: Fitting your worksheet to one page

In the above screen click on the Fit To: box and type: 1 page wide by 1 page tall. 
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If you need to make changes to your worksheet before printing, click on the Close button to return to your workbook. 

Task 4: Adjusting margins

In the Page Setup dialog box, click the Margins tab and enter the appropriate sizes(in inches or centimeters) 

Task 5: Setting Header/Footer to your worksheet

From the Page Setup dialog box, click on the Header/Footer tab to display the below screen. 
[image: ]





























In the Header box either you select a title from the drop down menu or enter your own title. Similarly for Footer box also you can set your own title. 

Click on OK. 

Task 6: Printing selected cells

Open cash.xls spreadsheet. 

Click on the row 2 button (or any other row containing data) to highlight the entire row. 
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Click on File, Print Area, Set Print Area. The preview screen should only display the selected cells. (Row 2). 

If the preview is satisfactory, click the Print button to print out only row 2. 

Click on File, Print Area, Clear Print Area to reset the Print Area. 


Creating charts and graphs

Task 1: Creating a Pie Chart

Open cash.xls spreadsheet. 
Select the cells A1 to G5 as shown below 
[image: ]








Click on Insert menu and click Chart option. This will start the Office Assistant, to guide you through creating chart. 

Follow the instructions in each step of the Wizard. The Assistant explains each step. 

At step 3, you can specify the Chart title, X-axis title and Y-axis title separately. 
At step 4, click As object in sheet 1, then click Finish. 

Your chart is now finished. Save as cash4. Your chart is saved with the spreadsheet. This type of chart is known as an embedded chart and is saved with its worksheet. 

Task 2: Creating charts when the data range is not continuous

Open cash4.xls 

If your requirement is create a chart to show expenditure for February, then first select cells A2 to A5. 

Hold down the Ctrl key and, while holding it down, select cells C2 to C5. Your screen should be similar to this one. 

Click on the Chart Wizard and create a column chart. Your screen should look similar to this. 










MS Excel	Page 34 of 40

[bookmark: page69]
If your chart doesn’t appear to show any data, you probably included some other cells, probably A1 and/or C1. If so, delete your chart and re-select the correct range. 

Task 3: Sizing a chart

· Open the cash3.xls created earlier. A screen similar to this one should appear. 
[image: ]


































The small black markers at each corner and mid-way along each side of the chart. These indicate that the chart is selected, and are called its selection squares. 

Click on the mid-point marker on the right-hand side, hold down the left mouse button and drag the mouse to the right about one inch(3cm), then release the mouse. The width of the chart will have increased. 

Now practice the same operation on the mid-point marker of each of the other sides of the chart. 

Now try the above, but this time on one of the four corner markers. Note that when you use these techniques, the whole chart changes in size, but it retains its original proportions. 
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Task 4: Deleting Charts

Make sure the chart is selected(the small black markers are visible). If not, move the mouse pointer into the chart area and click and release the left mouse button once. 

Press Delete to delete the chart. 

Task 5: Moving charts and graphs

Make the chart active. 
Move the mouse pointer into the chart area. 

Hold down the left mouse button and drag the chart to the desired position. 

Task 6: Chart headings and labels

While creating charts the step3 asks for Chart heading, labels for X-axis and Y-axis. You can define your own labels or click Next button so that the default values can be accepted. 
[image: ]

























For example Chart title is Expenditure, X-axis label is months and 

Y-axis label is Sales 
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Task 7: Editing chart items

Create the chart as shown below and save it as cash4.xls.
[image: ]




































Click the chart title(Expenditure). Selection markers(small black squares) will appear around the selected item. 

You can move or size the title in the same way that you can move or size a chart. Click the title box and drag it up by about one inch (3 cm), then release the mouse. 

You can format the title by selecting it, then right clicking and then selecting “Format Chart Title” from the drop down menu. You will get the below screen. 
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You can select font type, font style and font size as shown above 

Click OK. 

Task 8: Adding text to a chart

Open cash3.xls worksheet. 
Click View menu, click Toolbars, Drawing. 

Click the Text box icon on the Drawing toolbar. 
[image: ]









Draw a text box inside the chart area as shown below
[image: ]
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Click inside the text box. A flashing text cursor will appear. Now type Household Expenditure 

You can use the same procedure for any other text that you want to appear in charts. 

Task 9: Adding a legend to a chart

Create a pie chart as shown below.
[image: ]

[image: ]






















Display the Chart toolbar, by dropping down the view menu and clicking Toolbars, Chart. In the above figure the legend is already added. 

Click inside the pie chart, then click once on the add or delete legend button on the Chart toolbar. The legend will be added if not already present and removed if it is currently present. 






You can also add or delete a legend from the Chart, Chart options menu 
[image: ]

Task 10: Adding gridlines to a chart

Open cash3.xls worksheet and change chart type to Column chart. 

Click Chart, Chart options to display this box. 
[bookmark: page79]Click the Gridlines tab and tick the gridlines boxes required. 


Task 11: Adding data labels to a chart

Open cash3 worksheet and change chart type to pie chart. Drop-down the chart menu and click Chart options. 
Click on the Data Labels tab. 

Click on Show label and percent. Your screen should look similar to this. 
[image: ]
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MS POWER POINT
	Creating a slide :-

In the next step you will create a Title Slide for your presentation using the Blank Presentation template. You will be working in Slide View.
1. Open the PowerPoint program. Powerpoint automatically opens a new presentation. A new title slide will appear for you to work with.
[image: PowerPoint Dialogue box]
2. Alternatively, let's say you are already working in Powerpoint and want to create a new presentation. In the Open window, click the Microsoft Office Button. From the drop-down list, select New.
3. The New window will appear. Blank and recent is automatically highlighted in the list of options on the left. Click Create. A new Blank Presentation template will open with a new Title Slide in the Slide Layout (Normal) view.
[image: Selecting a new presentation]
4. If you don't want the Title Slide layout, you can easily change it to one of the other available layouts. In the Slides Group in the Home tab, click the arrow in the Layout button. All the slide layouts you can choose from will appear. Click on whichever one you want to use. The slide layout is now changed.
[image: Selecting a different layout]

Note: If you are already working in PowerPoint and want to create a new blank presentation, you can create a short cut by adding a New button [image: new button] to the Quick Access Toolbar. Click the arrow in the Quick Access Toolbar. From the drop-down list, select New. The New button is now added to the Quick Access Toolbar.
[image: Adding New to Quick Access Toolbar]
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Okay, now we have a Title Slide. But something's missing. Any guesses?
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Hey, who's interviewing who here?
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I know. The title!
	[image: http://www.actden.com/pp2007/images/suehead.gif]
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Good guess Sue. Let me show you how to add text to those blank slides.
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Adding text to a slide 
The Title Slide layout contains text boxes for a title and a subtitle. Try typing text into these boxes.
1. Click in the Title text box. A dashed line border with a circle in each corner and a square box at each midpoint appears around the text box indicating that it is selected.
2. Type a title.
[image: Typing a title text]
3. Click the Subtitle text box and type a subtitle.
Congratulations! You've just created your first slide in PowerPoint.
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Okay, you've created an impressive Title Slide for us. But that's just one slide! We need to create more slides or else we're going to have a pretty darn short presentation, aren't we?
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Wow, these hard-hitting investigative questions don't let up do they? You should be on 60 Minutes or start your own blog. Here, let me show you how to add another slide...
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	Adding another slide 
1. In the Slides Group in the Home tab, click on the top part of the New Slide button. A new slide is added which by default is the Title and Content layout slide.
[image: Insert New slide]
2.  Alternatively, to add a new slide with a different layout than the default, click the bottom part of New Slide button with the arrow beside the text, "New Slide". A drop-down list appears with all the slide layouts you can choose from. Click on the layout you want to use. A new slide with that layout is now added.
[image: Insert New slide with particular layout]
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Okay, so now we have multiple slides for our presentation. But how do we move from slide to slide?
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It's as easy as the click of a button. Literally. Just click and you've moved to a new slide.
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That's great! You've got enough moves to be on Dancing With The Stars!
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	Moving from slide to slide 
Let's say you've created several slides for your presentation. You've finished working on the last slide, and now you want to take a look at your other slides. Here's how you move from slide to slide in Slide View.
To move to a previous slide:
1. Click the upper double-arrow button [image: Previous Slide Button] on the lower right corner of the PowerPoint window. The previous slide will appear.
To move to the next slide:
1. Click the lower double-arrow button [image: Next Slide Button] on the lower right corner of the PowerPoint window.



Manipulating Your Slides Using the Format Menu: -
You can change the look of your slides with some of the options featured in the Format menu. 
The Slide Layout option allows you to change the format of your slides or will reapply a layout 
to a slide whose layout has been modified. The Slide Color Scheme option allows you to 
modify or reapply a color scheme of a particular slide. The Slide Background option allows 
you to set a background color, pattern, texture or image in your presentation. The Apply Design 
option allows you to use one of the MS PowerPoint templates. You can use this option to 
change the look of your presentation at any point. The Colors and Lines and AutoShape 
options allow you to set the line, fill colors, pattern, size, position, and text-wrapping properties 
for selected objects or shapes. 

Using the View Menu 
You can view and edit your presentation in five different modes. The default view in PowerPoint 
is the Slide view. This allows you to work with one slide at a time. You can use the Slide 
Sorter to view miniature versions of all the slides in your presentation. In this view you can 
reorder slides by selecting a slide and dragging it to its desired location. The Slide Sorter view is 
useful when editing slides because it allows you to jump to any place in your presentation rather 
than having to sequentially scroll through it. 

[image: ]

The Slide Show view allows you to see your presentation as it would appear to your audience. Each slide will be displayed at full screen size and will be presented in sequence. To move back and forth through slides press the “Page Up” or “Page Down” keys. To exit this mode press the “Esc” key. 
This menu also features some other helpful editing and viewing tools. The Grayscale option allows you to view your slides in black and white. You can add or change a header or footer using the Header and Footer option. The Comments option allows you to hide or display the comments boxes (if any) in your presentation. The Master option can prove quite useful. You can use any of the options in Master to change the default formatting and layout of each slide. For instance, using the Slide Master, you can set default font or insert an illustration, such as a company logo, to every slide.

Inserting and Editing an Organization Chart: 
If you would like to insert an organization chart into your presentation you can do so by double clicking on the slide with a layout that includes an organization chart. This will open an MS Organization Chart Window, which allows you to easily create and edit organization charts. Use the toolbar in the upper portion of the screen to add or delete the cells you need. When you are finished editing your chart, select File ->Update and return to <your filename>.ppt to insertthe chart in your presentation. If you wish to make changes to your chart later, simply double click on it.
[image: ]

Choose a slide with an organization chart box to add such a chart to your presentation.
Inserting and Editing a Graph: 

If you would like to insert a graph in your presentation you can do so by selecting a slide with a layout that includes a chart. After clicking on OK you must click on the portion of the slide that says DOUBLE CLICK TO ADD CHART. This will open up MS Graph, an application that allows you to create and edit graphs. 

[image: ]

Choose a slide with a chart box to add a graph.
A chart and spreadsheet will then appear on your screen. You can enter and delete data into the cells of the spreadsheet. Any change you make to the spreadsheet will be reflected in the chart. If you would like to change the chart type (e.g. to a pie chart), you can do so by going to the Chart Menu in MS Graph. You can change the actual feature of the graph by double clicking on that portion of the graph. Many of the features of MS Graph are similar to those of MS Excel. You can refer to the Microsoft Excel Documentation or use the MS Graph Help Menu if you need further assistance in editing your chart. The changes made to your chart in MS Graph will be automatically updated on your presentation once you go to Graph ->Quit and return to <your filename>. If you want to go back later and re-edit your graph, simply double click on it.
[image: ]
[image: ]
NOTE: Only the chart will appear in your presentation. The spreadsheet is simply for data entry.

Word Art:-
WordArt is a gallery of text styles that you can add to your Office documents to create decorative effects, such as shadowed or mirrored (reflected) text. In Word and PowerPoint, you can also convert existing text into WordArt.
You can use WordArt to add special text effects to your document. For example, you can stretch a title, skew text, make text fit a preset shape, or apply a gradient fill. This WordArt becomes an object that you can move or position in your document to add decoration or emphasis. You can modify or add to the text in an existing WordArt object whenever you want.
[image: Three examples of WordArt]
Create and Edit WordArt in PowerPoint
Create special effects--shadowed, skewered, rotated and stretched text--by using PowerPoint WordArt feature. WordArt objects are actually drawing objects and are not treated as text.
Create WordArt
1. Click on the INSERT WORDART button on the DRAWING toolbar (Looks like a tilted A)
2. Select the effect you want in the WordArt Gallery dialog box - click OK
3. Type your text in the EDIT WORDART TEXT dialog box - click OK
4. WordArt you created appears
5. Position and resize as necessary
[bookmark: section-1]Edit WordArt
1. Click on the WordArt to select it
2. Should see a WordArt toolbar
3. To edit the text, just doubleclick on the WordArt and the text box will open
4. To edit the color of the WordArt, click on the tipped Paint Bucket in the WordArt toolbar
5. Make sure Colors and Lines tab is chosen
6. Click on the down arrow next to the color (You have several choices)
7. To change the style of your WordArt, click on the WordArt Gallery icon in the WordArt toolbar
8. To change the shape, click on the abc icon in the WordArt toolbar
9. To make all your letters the same height, click on the WordArt Same Letter Heights icon in the WordArt toolbar
10. To change the orientation of your WordArt, click on the WordArt Vertical Text icon in the WordArt toolbar
11. To change the alignment of your WordArt, click on the WordArt alignment icon in the toolbar
12. To change the character spacing of your WordArt, click on the WordArt Character spacing icon in the toolbar
Layering Objects in PowerPoint 2007:-

PowerPoint layers objects in a stack; that is to say, the first object drawn or inserted is on the bottom of the stack, the next object appears on top of the previous object, and so on. You can change the position of an object in the stack by using one the Order commands. There are four order commands:
· Bring to Front – moves the selected object to the very top of the stack
· Send to Back – moves the selected object to the very back of the stack
· Bring Forward – moves the selected object one position up in the stack
· Send Backward – moves the seleted object one position back in the stack
[image: Arrange group under the Format tab]
In the example above, if we selected the rectangle and chose the Send to Back command, our text box would now be visible as the rectangle has now moved to the back of the layered stack.
To Change the Layering Order of Objects
1. Select the graphical object that you wish to move.
2. Click the Format tab under the Drawing Tools group.
3. To send an object backward or to the back of the stack, click the Send to Back arrow on the Arrange group and choose either Send to Back or Send Backward.
4. To bring an object forward or to the front of the stack, click the Bring to Front arrow on the Arrange group and choose either Bring to Front or Bring Forward.

Change Layers in PowerPoint 2007 Drawings

Whenever you have multiple objects on a PowerPoint slide, they can overlap. PowerPoint handles this problem by layering objects. The first object that you draw is at the bottom of the stack; the second object is on top of the first; the third is atop the second object; and so on. If two objects overlap, the one that’s at the highest layer wins; objects below it are partially covered. PowerPoint enables you to change the stacking order by moving objects toward the front or back so that they overlap just the way you want.
The Drawing Tools tab provides two controls that let you move an object forward or backward in the layer order:
[image: image0.jpg]
· Bring to Front: Brings the selected object to the top of the stack. Click the down arrow to reveal two subcommands. The Bring Forward command moves the object just one step closer to the top of the heap, whereas the Bring to Front command moves the object all the way to the top.
· Send to Back: Sends the selected object to the back of the stack. Click the down arrow to access the Send Backward subcommand, which sends the object one level down in the layer order.
Layering problems are most obvious when objects have a fill color. If an object has no fill color, objects behind it are allowed to show through. In this case, the layering doesn’t matter much.
To bring an object to the top of another, you might have to use the Bring Forward command several times. The reason is that even though the two objects appear to be adjacent, other objects might occupy the layers between them.
How to View Layers in Powerpoint

PowerPoint revolves around visual hooks, bringing slide show presentations to life via bulleted lists, animations, charts, videos and images. Among the other customization options offered by the program, PowerPoint allows you to layer these objects, one "atop" the other, in a single slide. Although viewing layers created by another presenter is as easy as opening and clicking through a PowerPoint presentation, you'll have to create your own layers if you want to view them in your own slide show.

Step 1
Add the objects that you wish to layer to your PowerPoint slide with the “Insert” tab. By default, the most recent object added to a slide appears on the top layer of objects. PowerPoint doesn't place a limit on the number of objects you can use per slide; it's up to you to limit the number of objects to avoid confusion.
Step 2
Click on a single object, or layer, to select it. You can modify its position among the other objects, which act as additional layers of your slide, under the “Drawing” tab on PowerPoint's main control ribbon. From here, click the “Arrange” button.
Step 3
Select one of the four options – “Bring to Front,” “Send to Back,” “Bring Forward” or “Send Backward” – to reposition the layer you have selected. “Bring Forward” moves the object up one layer while “Send Backward” moves it back one layer. “Bring to Front” puts it on the top layer and “Send to Back” positions it on the bottom layer.
Step 4
Save your presentation with layers intact as a PPT or PPTX file with PowerPoint's "Save" or “Save As” option. Open your creation in Microsoft PowerPoint or Microsoft PointPoint Viewer to see your layers in action.
How to Change Object Layers in PowerPoint 2013

Whenever you have more than one object on a PowerPoint 2013 slide, the potential exists for objects to overlap one another. Like most drawing programs, PowerPoint handles this problem by layering objects like a stack of plates. The first object that you draw is at the bottom of the stack; the second object is on top of the first; the third is atop the second object; and so on.
If two objects overlap, the one that’s at the highest layer wins; objects below it are partially covered. (Note that PowerPoint’s layers aren’t nearly as powerful as layers in other programs, such as Adobe Illustrator or AutoCAD. All they really do is set the stacking order when objects are placed on top of one another.)
So far, so good — but what if you don’t remember to draw the objects in the correct order? What if you draw a shape that you want to tuck behind a shape that you’ve already drawn, or what if you want to bring an existing shape to the top of the pecking order?
No problem. PowerPoint enables you to change the stacking order by moving objects toward the front or back so that they overlap just the way you want.
The Drawing Tools tab provides two controls that let you move an object forward or backward in the layer order:
· Bring to Front: Brings the chosen object to the top of the stack. Note that this button has a down arrow next to it. If you click this down arrow, you reveal a menu with two subcommands: Bring to Front and Bring Forward. The Bring Forward command moves the object just one step closer to the top of the heap, whereas the Bring to Front command moves the object all the way to the top.
· Send to Back: Sends the chosen object to the back of the stack. Again, this button has a down arrow next to it. You can click this down arrow to access the Send Backward subcommand, which sends the object one level down in the layer order.
Layering problems are most obvious when objects have a fill color. If an object has no fill color, objects behind it are allowed to show through. In this case, the layering doesn’t matter much.
To bring an object to the top of another, you might have to use the Bring Forward command several times. The reason is that even though the two objects appear to be adjacent, other objects might occupy the layers between them.

[image: http://www.actden.com/pp2007/images/white.gif]
Adding animation to images :-
When you animate an object, you add special visual or sound effects to it.
The following steps will show you how to animate a cartoon image while working in Slide View.
1. If you are not already in Normal (Slide) View, click the Normal View button in the View tab.
2. On the slide, click the cartoon image to select it.
3. From the Animations Group in the Animations tab, click on the Custom Animation button. The Custom Animation task pane will appear.
[image: Custom Animation button]
4. From the Custom Animation task pane, click the Add Effect button, select Entrance, then select Fly In. 
[image: Flying Effect button]
[image: Animated image]
[image: Animated image]
5. Decide how you want the effect to appear by using the options in the Custom Animation task pane: when it starts, its direction, and its speed.
[image: Options for the effect]
Inserting Sounds:-
[bookmark: cliporg]Inserting sounds using the Clip Organizer[image: Clip Organizer]
1. Select the slide to which you wish to add a sound.
2. In the Insert tab, under the Media Clips group, click the arrow on the [image: Sound] button. Choose Sound From Clip Organizer... to bring up the Clip Art task pane.
3. Use the Search Box to search by keyword (make sure Sounds is checked under Results Should Be...) and click Go to search.
4. Click the sound to insert it, or hover your mouse over it first, click on the menu arrow that appears, and choose Insert.
5. A pop-up box will appear asking you how you would like the sound to start in the presentation. Choose to either have it playautomatically or to have it play only when clicked.
6. A sound icon [image: Sound Icon] appears on your slide.

[bookmark: file]Inserting sounds from a file
1. Select the slide to which you wish to add a sound.
2. In the Insert tab, under the Media Clips group, click the arrow on the [image: Sound] button. Choose Sound From File... to bring up theInsert Sound dialog box.
3. Find the sound file on your computer using the "Look In" drop-down. Select the file and click Ok.
4. A pop-up box will appear asking you how you would like the sound to start in the presentation. Choose to either have it play automatically or to have it play only when clicked.
5. A sound icon [image: Sound Icon] appears on your slide.

[bookmark: recording]Recording your own sounds
PowerPoint 2007 offers different tools for recording narration.
Note: You must have a microphone attached to your computer for these instructions to work!
1. Select the slide to which you wish to add a sound.
2. In the Insert tab, under the Media Clips group, click the arrow on the [image: Sound] button. Choose Record Sound... to bring up the Record Sound dialog box.
[image: Record Sound dialog]
3. In the Name box, type an appropriate name for your sound.
4. When you are ready click RECORD [image: Record Sound] to record the sound.
5. When you are finished recording press STOP [image: Stop Recording].
Note: If you want to record more, or record in stages, you can click RECORD again after you have stopped recording to resume from where you left off.
6. To hear your sound click PLAY [image: Play Recording].
7. If you are not satisfied with your recording, click Cancel and start again.
If you are happy with the recording, click OK.
8. A sound icon [image: Sound Icon] appears on your slide.
Note: Unlike the last two options, PowerPoint does not automatically present you with the option to have your sound start automatically or when clicked. To change this option, select the sound icon and change the settings using the Sound Tools tab.
If you wish to change any of these settings, double-click on the CD icon and change the settings using Sound Tools tab.
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